tomee-embedded-maven-plugin 7.0.3 + eclipselink 2.7.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

tomee-embedded-maven-plugin 7.0.3 + eclipselink 2.7.0

gilbertoca
Hi guys (and girls), hope everyone is doing well!

Just set up eclipselink 2.7.0[1] in our pom. Trying to run the tomee embedded plugin stop at loading things:

tomee-embedded-eclipselink-2-7-0.txt

Building and running it with tomee-maven-plugin is ok.
I googled for the exception and found this discussion [2], but didn't see any issue with the set up.

Regards,

Gilberto


[1] http://www.eclipse.org/eclipselink/releases/2.7.php
[2] https://stackoverflow.com/questions/2877262/java-securityexception-signer-information-does-not-match?noredirect=1&lq=1
Reply | Threaded
Open this post in threaded view
|

Re: tomee-embedded-maven-plugin 7.0.3 + eclipselink 2.7.0

Romain Manni-Bucau
Hi Gilberto

The persistence.xml is missing from logs

Allso check you dont have a persistence api conflict maybe

Le 22 août 2017 21:13, "gilbertoca" <[hidden email]> a écrit :

> Hi guys (and girls), hope everyone is doing well!
>
> Just set up eclipselink 2.7.0[1] in our pom. Trying to run the tomee
> embedded plugin stop at loading things:
>
> tomee-embedded-eclipselink-2-7-0.txt
> <http://tomee-openejb.979440.n4.nabble.com/file/n4682483/
> tomee-embedded-eclipselink-2-7-0.txt>
>
> Building and running it with tomee-maven-plugin is ok.
> I googled for the exception and found this discussion [2], but didn't see
> any issue with the set up.
>
> Regards,
>
> Gilberto
>
>
> [1] http://www.eclipse.org/eclipselink/releases/2.7.php
> [2]
> https://stackoverflow.com/questions/2877262/java-securityexception-signer-
> information-does-not-match?noredirect=1&lq=1
>
>
>
> --
> View this message in context: http://tomee-openejb.979440.
> n4.nabble.com/tomee-embedded-maven-plugin-7-0-3-
> eclipselink-2-7-0-tp4682483.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: tomee-embedded-maven-plugin 7.0.3 + eclipselink 2.7.0

gilbertoca
Romain Manni-Bucau wrote
Hi Gilberto

The persistence.xml is missing from logs
gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ find -iname "*persis*"
./target/gace/WEB-INF/classes/META-INF/persistence.xml
./target/classes/META-INF/persistence.xml
./src/main/resources/META-INF/persistence.xml
./.distribution/apache-tomee/webapps/gace/WEB-INF/classes/META-INF/persistence.xml

Romain Manni-Bucau wrote
Allso check you dont have a persistence api conflict maybe
[13:54] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ mvn dependency:tree|grep "javax.persistence"
[INFO] |  +- org.eclipse.persistence:javax.persistence:jar:2.1.1:provided
[13:58] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ mvn dependency:tree|grep "javax."
[INFO] +- javax:javaee-web-api:jar:7.0:provided
[INFO] |  +- javax.validation:validation-api:jar:1.1.0.Final:provided
[INFO] +- javax.el:javax.el-api:jar:3.0.0:provided
[INFO] +- org.glassfish.web:javax.el:jar:2.2.6:provided
[INFO] |  +- org.eclipse.persistence:javax.persistence:jar:2.1.1:provided
[INFO] |  \- org.glassfish:javax.json:jar:1.0.4:provided
[13:58] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ 

Change back to 2.6.4 works normally.
Thank you.
Reply | Threaded
Open this post in threaded view
|

Re: tomee-embedded-maven-plugin 7.0.3 + eclipselink 2.7.0

gilbertoca
Sorry, the last email shows info using 2.6.4.

Here is the info using 2.7.0:

14:03] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ find -iname "*persis*"
./target/gace/WEB-INF/classes/META-INF/persistence.xml
./target/classes/META-INF/persistence.xml
./src/main/resources/META-INF/persistence.xml
./.distribution/apache-tomee/webapps/gace/WEB-INF/classes/META-INF/persistence.xml

[14:04] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ mvn dependency:tree|grep "javax."
[INFO] +- javax:javaee-web-api:jar:7.0:provided
[INFO] |  +- javax.validation:validation-api:jar:1.1.0.Final:provided
[INFO] +- javax.el:javax.el-api:jar:3.0.0:provided
[INFO] +- org.glassfish.web:javax.el:jar:2.2.6:provided
[INFO] |  +- org.eclipse.persistence:javax.persistence:jar:2.2.0:provided
[INFO] |  \- org.glassfish:javax.json:jar:1.0.4:provided
[14:04] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ 

14:04] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ mvn dependency:tree|grep "eclipse"
[INFO] |  +- eclipse:jdtcore:jar:3.1.0:compile
[INFO] +- org.apache.tomee:openejb-core-eclipselink:jar:7.0.3:test
[INFO] +- org.eclipse.persistence:eclipselink:jar:2.7.0:test
[INFO] |  +- org.eclipse.persistence:javax.persistence:jar:2.2.0:provided
[INFO] |  +- org.eclipse.persistence:commonj.sdo:jar:2.1.1:test
[INFO] +- org.eclipse.persistence:org.eclipse.persistence.jpa.modelgen.processor:jar:2.7.0:provided
[INFO] |  +- org.eclipse.persistence:org.eclipse.persistence.core:jar:2.7.0:provided
[INFO] |  |  \- org.eclipse.persistence:org.eclipse.persistence.asm:jar:2.7.0:provided
[INFO] |  \- org.eclipse.persistence:org.eclipse.persistence.jpa:jar:2.7.0:provided
[INFO] |     +- org.eclipse.persistence:org.eclipse.persistence.antlr:jar:2.7.0:provided
[INFO] |     \- org.eclipse.persistence:org.eclipse.persistence.jpa.jpql:jar:2.7.0:provided
[14:07] gilberto.andrade@BEM-INF007:gace (ticket/86 *+$ u+8) $ 
Reply | Threaded
Open this post in threaded view
|

Re: tomee-embedded-maven-plugin 7.0.3 + eclipselink 2.7.0

Romain Manni-Bucau
Hi Giberto,

try to cleanup API (you have most of them duplicated) and use only
org.apache.tomee:javaee-api:7.0-1.

Also maybe give a try removing one of both persistence.xml


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2017-08-23 19:07 GMT+02:00 gilbertoca <[hidden email]>:

> Sorry, the last email shows info using 2.6.4.
>
> Here is the info using 2.7.0:
>
>
>
>
>
>
>
>
>
> --
> View this message in context: http://tomee-openejb.979440.
> n4.nabble.com/tomee-embedded-maven-plugin-7-0-3-eclipselink-2-7-0-
> tp4682483p4682487.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>