archetype

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

archetype

chongma
i just tried to create archetype using mvn archetype:generate
-DarchetypeGroupId=org.apache.openejb.maven
-DarchetypeArtifactId=tomee-webapp-archetype -DarchetypeVersion=1.7.1
but using 7.0.3, 7.0.4 etc but it doesn't exist.  do we need to create
some new archetypes?
the 1.7.1 uses EJB but it would be good if it was updated to use CDI?
i created the project openjpa-reproducer and it didn't warn me that the
"-" symbol wouldn't work in package names so i had to start again as the
classes were all messed up

Reply | Threaded
Open this post in threaded view
|

Re: archetype

Romain Manni-Bucau
Tomee uses tomee instead of openejb in its group for v7.

Le 17 mars 2018 17:44, "Matthew Broadhead" <[hidden email]>
a écrit :

> i just tried to create archetype using mvn archetype:generate
> -DarchetypeGroupId=org.apache.openejb.maven -DarchetypeArtifactId=tomee-webapp-archetype
> -DarchetypeVersion=1.7.1
> but using 7.0.3, 7.0.4 etc but it doesn't exist.  do we need to create
> some new archetypes?
> the 1.7.1 uses EJB but it would be good if it was updated to use CDI?
> i created the project openjpa-reproducer and it didn't warn me that the
> "-" symbol wouldn't work in package names so i had to start again as the
> classes were all messed up
>
>
Reply | Threaded
Open this post in threaded view
|

Re: archetype

chongma
oh yeah of course

On 17/03/2018 19:22, Romain Manni-Bucau wrote:

> Tomee uses tomee instead of openejb in its group for v7.
>
> Le 17 mars 2018 17:44, "Matthew Broadhead" <[hidden email]>
> a écrit :
>
>> i just tried to create archetype using mvn archetype:generate
>> -DarchetypeGroupId=org.apache.openejb.maven -DarchetypeArtifactId=tomee-webapp-archetype
>> -DarchetypeVersion=1.7.1
>> but using 7.0.3, 7.0.4 etc but it doesn't exist.  do we need to create
>> some new archetypes?
>> the 1.7.1 uses EJB but it would be good if it was updated to use CDI?
>> i created the project openjpa-reproducer and it didn't warn me that the
>> "-" symbol wouldn't work in package names so i had to start again as the
>> classes were all messed up
>>
>>