Tomee7 plus and plume not work with netbeans

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Tomee7 plus and plume not work with netbeans

mauro2java2011
This post was updated on .
Hi all.
I have install tomee7 plus and plume into netbeans 8.1 . And my jdk is jdk 7  and 8.

I have tried botht without and with catalinabase configured.

I have  uncomment the user into user xml file. I have added slso the role manager-script into roles .
So tge user tomee now came with roles "tomee-admin, manager-gui, manager-script"
But when i try from rhe server list to run tomee7 not run. It says not possible start .
 But not othet server are started .
So is not port conflict in 8080.

Please  any has tge same problem ?

I have used tomed from 1.5 version and it work all times.
But from tomee7 not work.
Mauro

Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

sgjava
I've launched TomEE from Netbeans with no problems (TomEE is basically
Tomcat+OpenEJB). But now I just use TomEE Embedded unit my unit tests. If
you want to keep an instance running look at tomee-maven-plugin. Then you
are not tied to your IDE.

On Sun, Jun 12, 2016 at 5:43 AM, mauro2java2011 <[hidden email]>
wrote:

> Hi all.
> I have install tomee7 plus and plume into netbeans 8.1 . And my jdk is jdk
> 7
> and 8.
>
> I have tried botht without and with catalinabase configured.
>
> I have  uncomment the user into user xml file. I have added slso the role
> manager-script into roles .
> So tge user tomee now came with roles "tomee-admin, manager-gui,
> mabager-script"
> But when i try from rhe server list to run tomee7 not run. It says not
> possible start .
>  But not othet server are started .
> So is not port conflict in 8080.
>
> Please  any has tge same problem ?
>
> I have used tomed from 1.5 cersion and it work all times.
> But from tomee7 not work.
> Mauro
>
>
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-bit-work-with-netbeabs-tp4678852.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>



--
Steven P. Goldsmith
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

Romain Manni-Bucau
In reply to this post by mauro2java2011
Hi Mauro

We spoke of some blacklist properties and tomee remote webapp activation on
another thread. Maybe it is linked.
Le 12 juin 2016 12:22, "mauro2java2011" <[hidden email]> a écrit :

> Hi all.
> I have install tomee7 plus and plume into netbeans 8.1 . And my jdk is jdk
> 7
> and 8.
>
> I have tried botht without and with catalinabase configured.
>
> I have  uncomment the user into user xml file. I have added slso the role
> manager-script into roles .
> So tge user tomee now came with roles "tomee-admin, manager-gui,
> mabager-script"
> But when i try from rhe server list to run tomee7 not run. It says not
> possible start .
>  But not othet server are started .
> So is not port conflict in 8080.
>
> Please  any has tge same problem ?
>
> I have used tomed from 1.5 cersion and it work all times.
> But from tomee7 not work.
> Mauro
>
>
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-bit-work-with-netbeabs-tp4678852.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

agumbrecht
It's linked, and will be a common issue it seems to be. May be worth adding
to the download page?

http://www.tomitribe.com - @AndyGeeDe - On a small screen device.
On 12 Jun 2016 16:56, "Romain Manni-Bucau" <[hidden email]> wrote:

> Hi Mauro
>
> We spoke of some blacklist properties and tomee remote webapp activation on
> another thread. Maybe it is linked.
> Le 12 juin 2016 12:22, "mauro2java2011" <[hidden email]> a
> écrit :
>
> > Hi all.
> > I have install tomee7 plus and plume into netbeans 8.1 . And my jdk is
> jdk
> > 7
> > and 8.
> >
> > I have tried botht without and with catalinabase configured.
> >
> > I have  uncomment the user into user xml file. I have added slso the role
> > manager-script into roles .
> > So tge user tomee now came with roles "tomee-admin, manager-gui,
> > mabager-script"
> > But when i try from rhe server list to run tomee7 not run. It says not
> > possible start .
> >  But not othet server are started .
> > So is not port conflict in 8080.
> >
> > Please  any has tge same problem ?
> >
> > I have used tomed from 1.5 cersion and it work all times.
> > But from tomee7 not work.
> > Mauro
> >
> >
> >
> >
> >
> > --
> > View this message in context:
> >
> http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-bit-work-with-netbeabs-tp4678852.html
> > Sent from the TomEE Users mailing list archive at Nabble.com.
> >
>
    --
    Andy Gumbrecht

    http://www.tomitribe.com
    agumbrecht@tomitribe.com
    https://twitter.com/AndyGeeDe

    TomEE treibt Tomitribe ! | http://tomee.apache.org
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

Romain Manni-Bucau
We have an IDE page. Surely better if anyone wants to fix it.
Le 12 juin 2016 18:09, "Andy Gumbrecht" <[hidden email]> a écrit :

> It's linked, and will be a common issue it seems to be. May be worth adding
> to the download page?
>
> http://www.tomitribe.com - @AndyGeeDe - On a small screen device.
> On 12 Jun 2016 16:56, "Romain Manni-Bucau" <[hidden email]> wrote:
>
> > Hi Mauro
> >
> > We spoke of some blacklist properties and tomee remote webapp activation
> on
> > another thread. Maybe it is linked.
> > Le 12 juin 2016 12:22, "mauro2java2011" <[hidden email]> a
> > écrit :
> >
> > > Hi all.
> > > I have install tomee7 plus and plume into netbeans 8.1 . And my jdk is
> > jdk
> > > 7
> > > and 8.
> > >
> > > I have tried botht without and with catalinabase configured.
> > >
> > > I have  uncomment the user into user xml file. I have added slso the
> role
> > > manager-script into roles .
> > > So tge user tomee now came with roles "tomee-admin, manager-gui,
> > > mabager-script"
> > > But when i try from rhe server list to run tomee7 not run. It says not
> > > possible start .
> > >  But not othet server are started .
> > > So is not port conflict in 8080.
> > >
> > > Please  any has tge same problem ?
> > >
> > > I have used tomed from 1.5 cersion and it work all times.
> > > But from tomee7 not work.
> > > Mauro
> > >
> > >
> > >
> > >
> > >
> > > --
> > > View this message in context:
> > >
> >
> http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-bit-work-with-netbeabs-tp4678852.html
> > > Sent from the TomEE Users mailing list archive at Nabble.com.
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

mauro2java2011
When into netbens8.1 into win7  i try to run i get:
Using JRE_HOME="C:\Program Files\Java\jdk1.8.0_74"

"127.0.0.1" is not recognized like command inside or external, an executable program or one file batch.

But also into ubuntu it not work.
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

Romain Manni-Bucau
Not sure what this means to be honest (where you see that) but I'm not a
netbeans user.

On TomEE side ensure to set at least:

tomee.remote.support=true
tomee.serialization.class.blacklist=-


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
<http://www.tomitribe.com> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2016-06-13 8:49 GMT+02:00 mauro2java2011 <[hidden email]>:

> When into netbens8.1 into win7  i try to run i get:
> Using JRE_HOME="C:\Program Files\Java\jdk1.8.0_74"
>
> "127.0.0.1" is not recognized like command inside or external, an
> executable
> program or one file batch.
>
> But also into ubuntu it not work.
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-not-work-with-netbeans-tp4678852p4678858.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

mauro2java2011
I have unchecked the use ide proxy setting from the properties  of my ttomer 7 plus and plume.
Now into my pc with win7, jdk 1.8 and tomee 7 and netbeans 8.1 it work!

But into my ubuntu 10.04  with  jdk 1.7 tomrd 7 and netbeans 8.02 i still get after 2 minutes the message impossible start tomee.
But it is started in effect. The netbeans not recognise that is starded.

So on win7 is ok but into ubuntu is not ok

Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

Romain Manni-Bucau
Netbeans version is different, can it be the cause?
Le 16 juin 2016 13:48, "mauro2java2011" <[hidden email]> a écrit :

> I have unchecked the use ide proxy setting from the properties  of my
> ttomer
> 7 plus and plume.
> Now into my pc with win7, jdk 1.8 and tomee 7 and netbeans 8.1 it work!
>
> But into my ubuntu 10.04  with  jdk 1.7 tomrd 7 and netbeans 8.02 i still
> get after 2 minutes the message impossible start tomee.
> But it is started in effect. The netbeans not recognise that is starded.
>
> So on win7 is ok but into ubuntu is not ok
>
>
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-not-work-with-netbeans-tp4678852p4678927.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

mauro2java2011
not think
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

Romain Manni-Bucau
Side note: this is a question for netbeans forum even if I know tomee list
is pretty nice :D


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
<http://www.tomitribe.com> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2016-06-16 15:16 GMT+02:00 mauro2java2011 <[hidden email]>:

> not think
>
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-not-work-with-netbeans-tp4678852p4678929.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

mauro2java2011
This post was updated on .
hi i have investigated the differences into server.xml of tomee7 from other old version.
I have noted the :
   
   ORGINAL  into server.xml of tomee7
    <Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" xpoweredBy="false" server="Apache TomEE" />
   
    END ORGINAL
----------------------------------------------------------------------------------
from apache-tomee-plus-1.7.0
<Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" />

 END from apache-tomee-plus-1.7.0

-----------------------------------------------------------
   
     CORRECT FROM ME and it work!!!  
     <Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" xpoweredBy="false"/>
    END  CORRECT FROM ME and it work!!!

-------------------------------------------------------
i have removed the attribute server="Apache TomEE"  not present into server.xml of tomee.1.7.0
and now it worked.


SO i you ask:
1) The remove of attribute server="Apache TomEE"  can present problem on tomee?

2)i haVE noted that another new  attribute is present respect to old version tomee1.7.0.
 is :    xpoweredBy="false"

i not have removed it. 
3)what are the two new attributes? Their functionality what is it?

Tank you very much for your attention.
Mauro

Reply | Threaded
Open this post in threaded view
|

Re: Tomee7 plus and plume bit work with netbeabs

Romain Manni-Bucau
Le 18 juin 2016 11:32, "mauro2java2011" <[hidden email]> a écrit :
>
> hi i have investigated the difeerences int oserver.xml of tomee7 from
other
> old version.
> I have noted the :
>
>   * ORGINAL  into server.xml of tomee7*
>     <Connector port="8080" protocol="HTTP/1.1"
>                connectionTimeout="20000"
>                redirectPort="8443" xpoweredBy="false" server="Apache
TomEE"
> />
>
>     *END ORGINAL *
>
----------------------------------------------------------------------------------

> *from apache-tomee-plus-1.7.0 *
> <Connector port="8080" protocol="HTTP/1.1"
>                connectionTimeout="20000"
>                redirectPort="8443" />
>
>  *END from apache-tomee-plus-1.7.0 *
>
> -----------------------------------------------------------
>
>      *CORRECT FROM ME and it work!!!  *
>      <Connector port="8080" protocol="HTTP/1.1"
>                connectionTimeout="20000"
>                redirectPort="8443" xpoweredBy="false"/>
>    * END  MESSO DA ME*
>
> -------------------------------------------------------
> i have removed the attribute *server="Apache TomEE"*  not presente into
> server.xml of tomee.1.7.0
> and now it worked.
>
>
> SO i you ask:
> 1) The remove of attribute server="Apache TomEE"  can present problem on
> tomee?
>

No pb for tomee bit some tools like netbeans expect it.

> 2)i haVE noted that another new  attribute is present respect to old
version
> tomee1.7.0.
>  is :  *  xpoweredBy="false"*
>
> *i not have removed it.*
> 3)what are the two new attributes? Their functionality what is it?
>

Was to differentiate tomcat from tomee through response header. Will be
deactivated by default on next release.

> Tank you very much for your attention.
> Mauro
>
>
>
>
>
> --
> View this message in context:
http://tomee-openejb.979440.n4.nabble.com/Tomee7-plus-and-plume-not-work-with-netbeans-tp4678852p4678956.html
> Sent from the TomEE Users mailing list archive at Nabble.com.