TomEE builds running with JDK7

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

TomEE builds running with JDK7

exabrial12
I'm guessing Maven Central probably recently started requiring vTLS1.2+. Is
there a way to add -Dhttps.protocols=TLSv1.2 to the MAVEN_OPTS on the
builder?


Caused by: javax.net.ssl.SSLException: Received fatal alert:
protocol_version
        at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
        at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
        at sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:1979)
        at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1086)
        at
sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1332)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1359)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1343)




--
Sent from: http://tomee-openejb.979440.n4.nabble.com/TomEE-Dev-f982480.html
Reply | Threaded
Open this post in threaded view
|

Re: TomEE builds running with JDK7

jgallimore
Yes - I'll do that.

On Tue, Nov 6, 2018 at 10:06 PM exabrial12 <[hidden email]> wrote:

> I'm guessing Maven Central probably recently started requiring vTLS1.2+. Is
> there a way to add -Dhttps.protocols=TLSv1.2 to the MAVEN_OPTS on the
> builder?
>
>
> Caused by: javax.net.ssl.SSLException: Received fatal alert:
> protocol_version
>         at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
>         at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
>         at
> sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:1979)
>         at
> sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1086)
>         at
>
> sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1332)
>         at
> sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1359)
>         at
> sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1343)
>
>
>
>
> --
> Sent from:
> http://tomee-openejb.979440.n4.nabble.com/TomEE-Dev-f982480.html
>
Reply | Threaded
Open this post in threaded view
|

Re: TomEE builds running with JDK7

jgallimore
For reference, the buildbot config is here:
https://svn.apache.org/repos/infra/infrastructure/buildbot/aegis/buildmaster/master1/projects/tomee.conf

If you update that and commit, the changes get applied right away. I don't
recall if its any committer, or just those on the PMC with access. If you
do change the config, you should subscribe to [hidden email]  so you can
get notifications that things are broken if you mess it up (so you can fix
it :-) ).

Your specific build error is caused by CXF 3.1.18 not being available yet
as opposed to SSL config, so I have changed the CXF version to 3.1.17, and
we'll see what the CI build output is. If we see the same errors with that
CXF version, we'll change the config.

Does that sound ok?

Jon

On Wed, Nov 7, 2018 at 11:10 AM Jonathan Gallimore <
[hidden email]> wrote:

> Yes - I'll do that.
>
> On Tue, Nov 6, 2018 at 10:06 PM exabrial12 <[hidden email]> wrote:
>
>> I'm guessing Maven Central probably recently started requiring vTLS1.2+.
>> Is
>> there a way to add -Dhttps.protocols=TLSv1.2 to the MAVEN_OPTS on the
>> builder?
>>
>>
>> Caused by: javax.net.ssl.SSLException: Received fatal alert:
>> protocol_version
>>         at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
>>         at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
>>         at
>> sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:1979)
>>         at
>> sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1086)
>>         at
>>
>> sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1332)
>>         at
>> sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1359)
>>         at
>> sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1343)
>>
>>
>>
>>
>> --
>> Sent from:
>> http://tomee-openejb.979440.n4.nabble.com/TomEE-Dev-f982480.html
>>
>
Reply | Threaded
Open this post in threaded view
|

Re: TomEE builds running with JDK7

exabrial12
Yep. 3.1.8 hasn't been released yet.



--
Sent from: http://tomee-openejb.979440.n4.nabble.com/TomEE-Dev-f982480.html
Reply | Threaded
Open this post in threaded view
|

Re: TomEE builds running with JDK7

jgallimore
Build looks to have passed with CXF 3.1.17.

On Wed, 7 Nov 2018, 18:35 exabrial12 <[hidden email] wrote:

> Yep. 3.1.8 hasn't been released yet.
>
>
>
> --
> Sent from:
> http://tomee-openejb.979440.n4.nabble.com/TomEE-Dev-f982480.html
>