TomEE and Arquillian

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

TomEE and Arquillian

Makarov Alexey
Hello!
I use "TomEE 8 plus", and I want to write integration tests.
I wrote small test and set some config in pom.xml. When I start tests and look at console I see:
"INFO: Downloading org.apache.tomee:apache-tomee:8.0.0:zip:webprofile please wait...",- my maven download webprofile, I use ActiveMQ and as far as I understand, I need plus or plume profile. How I can do this?

My pom.xml:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>ru.ritos</groupId>
    <artifactId>ritos-backend</artifactId>
    <version>1.0-SNAPSHOT</version>
    <packaging>war</packaging>

    <name>ritos-backend</name>

    <properties>
        <endorsed.dir>${project.build.directory}/endorsed</endorsed.dir>
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
        <deltaspike.version>1.9.1</deltaspike.version>
        <tomee.version>8.0.0</tomee.version>
        <tomee.classifier>plus</tomee.classifier>
    </properties>
   
    <dependencyManagement>
        <dependencies>
            <dependency>
                <groupId>org.apache.deltaspike.distribution</groupId>
                <artifactId>distributions-bom</artifactId>
                <version>${deltaspike.version}</version>
                <type>pom</type>
                <scope>import</scope>
            </dependency>
            <dependency>
                <groupId>org.jboss.arquillian</groupId>
                <artifactId>arquillian-bom</artifactId>
                <version>1.5.0.Final</version>
                <scope>import</scope>
                <type>pom</type>
            </dependency>
        </dependencies>
    </dependencyManagement>
   
    <dependencies>
        <dependency>
            <groupId>redis.clients</groupId>
            <artifactId>jedis</artifactId>
            <version>3.1.0</version>
        </dependency>
        <dependency>
            <groupId>commons-codec</groupId>
            <artifactId>commons-codec</artifactId>
            <version>1.13</version>
        </dependency>
        <dependency>
            <groupId>org.apache.commons</groupId>
            <artifactId>commons-lang3</artifactId>
            <version>3.9</version>
        </dependency>
        <dependency>
            <groupId>org.apache.httpcomponents</groupId>
            <artifactId>httpclient</artifactId>
            <version>4.5.10</version>
        </dependency>
        <dependency>
            <groupId>org.postgresql</groupId>
            <artifactId>postgresql</artifactId>
            <version>42.2.8</version>
        </dependency>
        <dependency>
            <groupId>javax</groupId>
            <artifactId>javaee-api</artifactId>
            <version>8.0</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.deltaspike.core</groupId>
            <artifactId>deltaspike-core-api</artifactId>
            <scope>compile</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.deltaspike.core</groupId>
            <artifactId>deltaspike-core-impl</artifactId>
            <scope>runtime</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.deltaspike.modules</groupId>
            <artifactId>deltaspike-security-module-api</artifactId>
            <scope>compile</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.deltaspike.modules</groupId>
            <artifactId>deltaspike-security-module-impl</artifactId>
            <scope>runtime</scope>
        </dependency>
        <!-- Hibernate -->
        <dependency>
            <groupId>org.hibernate</groupId>
            <artifactId>hibernate-entitymanager</artifactId>
            <version>5.3.13.Final</version>
        </dependency>
       
        <dependency>
            <groupId>com.vladmihalcea</groupId>
            <artifactId>hibernate-types-52</artifactId>
            <version>2.7.1</version>
        </dependency>
        <!-- unit testing -->
        <dependency>
            <groupId>org.junit.jupiter</groupId>
            <artifactId>junit-jupiter-engine</artifactId>
            <version>5.5.2</version>
            <scope>test</scope>
        </dependency>
        <dependency>
            <groupId>org.jboss.weld</groupId>
            <artifactId>weld-junit5</artifactId>
            <version>2.0.1.Final</version>
            <scope>test</scope>
        </dependency>
        <dependency>
            <groupId>org.mockito</groupId>
            <artifactId>mockito-core</artifactId>
            <version>3.1.0</version>
            <scope>test</scope>
        </dependency>
        <!--<dependency>
            <groupId>org.glassfish</groupId>
            <artifactId>javax.json</artifactId>
            <version>1.1</version>
            <scope>test</scope>
        </dependency>-->
       
        <!-- integration testing -->
       
        <dependency>
            <groupId>junit</groupId>
            <artifactId>junit</artifactId>
            <version>4.12</version>
            <scope>test</scope>
        </dependency>
       
        <dependency>
            <groupId>org.jboss.arquillian.junit</groupId>
            <artifactId>arquillian-junit-container</artifactId>
            <version>1.5.0.Final</version>
            <scope>test</scope>
        </dependency>
       
        <dependency>
            <groupId>org.apache.tomee</groupId>
            <artifactId>arquillian-tomee-remote</artifactId>
            <version>${tomee.version}</version>
            <scope>test</scope>
        </dependency>
       
        <dependency>
            <groupId>org.apache.tomee</groupId>
            <artifactId>apache-tomee</artifactId>
            <version>${tomee.version}</version>
            <classifier>plus</classifier>
            <type>zip</type>
            <scope>test</scope>
        </dependency>
       
        <dependency>
            <groupId>org.jboss.shrinkwrap.resolver</groupId>
            <artifactId>shrinkwrap-resolver-depchain</artifactId>
            <version>3.1.3</version>
            <scope>test</scope>
            <type>pom</type>
        </dependency>
       
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                    <compilerArguments>
                        <endorseddirs>${endorsed.dir}</endorseddirs>
                    </compilerArguments>
                    <showDeprecation>true</showDeprecation>
                </configuration>
            </plugin>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-war-plugin</artifactId>
                <version>2.3</version>
                <configuration>
                    <failOnMissingWebXml>false</failOnMissingWebXml>
                </configuration>
            </plugin>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-dependency-plugin</artifactId>
                <version>2.6</version>
                <executions>
                    <execution>
                        <phase>validate</phase>
                        <goals>
                            <goal>copy</goal>
                        </goals>
                        <configuration>
                            <outputDirectory>${endorsed.dir}</outputDirectory>
                            <silent>true</silent>
                            <artifactItems>
                                <artifactItem>
                                    <groupId>javax</groupId>
                                    <artifactId>javaee-endorsed-api</artifactId>
                                    <version>7.0</version>
                                    <type>jar</type>
                                </artifactItem>
                            </artifactItems>
                        </configuration>
                    </execution>
                </executions>
            </plugin>
           
            <plugin>
                <groupId>org.apache.tomee.maven</groupId>
                <artifactId>tomee-maven-plugin</artifactId>
                <version>${tomee.version}</version>
                <configuration>
                    <tomeeVersion>${tomee.version}</tomeeVersion>
                    <tomeeClassifier>${tomee.classifier}</tomeeClassifier>
                </configuration>
            </plugin>
           
        </plugins>
    </build>
</project>

Thank you!

--
With best regards,
Alexey Makarov

Reply | Threaded
Open this post in threaded view
|

Re: TomEE and Arquillian

jgallimore
You should be able to specify it using the "classifier" property in
arquillian.xml:

<arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <container qualifier="tomee" default="true">
    <configuration>
      <property name="classifier">plus</property>
      <property name="httpPort">-1</property>
      <property name="stopPort">-1</property>
      <property name="tomcatVersion"></property>
      <property name="openejbVersion">${tomee.version}</property>
      <property name="dir">target/apache-tomee-remote</property>
      <property
name="appWorkingDir">target/arquillian-test-working-dir</property>
    </configuration>
  </container>
</arquillian>

Let us know how you get on!

Jon

On Tue, Nov 12, 2019 at 11:30 AM Makarov Alexey <[hidden email]> wrote:

> Hello!
> I use "TomEE 8 plus", and I want to write integration tests.
> I wrote small test and set some config in pom.xml. When I start tests and
> look at console I see:
> "INFO: Downloading org.apache.tomee:apache-tomee:8.0.0:zip:webprofile
> please wait...",- my maven download webprofile, I use ActiveMQ and as far
> as I understand, I need plus or plume profile. How I can do this?
>
> My pom.xml:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
> http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="
> http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>     <modelVersion>4.0.0</modelVersion>
>
>     <groupId>ru.ritos</groupId>
>     <artifactId>ritos-backend</artifactId>
>     <version>1.0-SNAPSHOT</version>
>     <packaging>war</packaging>
>
>     <name>ritos-backend</name>
>
>     <properties>
>         <endorsed.dir>${project.build.directory}/endorsed</endorsed.dir>
>         <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
>         <deltaspike.version>1.9.1</deltaspike.version>
>         <tomee.version>8.0.0</tomee.version>
>         <tomee.classifier>plus</tomee.classifier>
>     </properties>
>
>     <dependencyManagement>
>         <dependencies>
>             <dependency>
>                 <groupId>org.apache.deltaspike.distribution</groupId>
>                 <artifactId>distributions-bom</artifactId>
>                 <version>${deltaspike.version}</version>
>                 <type>pom</type>
>                 <scope>import</scope>
>             </dependency>
>             <dependency>
>                 <groupId>org.jboss.arquillian</groupId>
>                 <artifactId>arquillian-bom</artifactId>
>                 <version>1.5.0.Final</version>
>                 <scope>import</scope>
>                 <type>pom</type>
>             </dependency>
>         </dependencies>
>     </dependencyManagement>
>
>     <dependencies>
>         <dependency>
>             <groupId>redis.clients</groupId>
>             <artifactId>jedis</artifactId>
>             <version>3.1.0</version>
>         </dependency>
>         <dependency>
>             <groupId>commons-codec</groupId>
>             <artifactId>commons-codec</artifactId>
>             <version>1.13</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.commons</groupId>
>             <artifactId>commons-lang3</artifactId>
>             <version>3.9</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.httpcomponents</groupId>
>             <artifactId>httpclient</artifactId>
>             <version>4.5.10</version>
>         </dependency>
>         <dependency>
>             <groupId>org.postgresql</groupId>
>             <artifactId>postgresql</artifactId>
>             <version>42.2.8</version>
>         </dependency>
>         <dependency>
>             <groupId>javax</groupId>
>             <artifactId>javaee-api</artifactId>
>             <version>8.0</version>
>             <scope>provided</scope>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.deltaspike.core</groupId>
>             <artifactId>deltaspike-core-api</artifactId>
>             <scope>compile</scope>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.deltaspike.core</groupId>
>             <artifactId>deltaspike-core-impl</artifactId>
>             <scope>runtime</scope>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.deltaspike.modules</groupId>
>             <artifactId>deltaspike-security-module-api</artifactId>
>             <scope>compile</scope>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.deltaspike.modules</groupId>
>             <artifactId>deltaspike-security-module-impl</artifactId>
>             <scope>runtime</scope>
>         </dependency>
>         <!-- Hibernate -->
>         <dependency>
>             <groupId>org.hibernate</groupId>
>             <artifactId>hibernate-entitymanager</artifactId>
>             <version>5.3.13.Final</version>
>         </dependency>
>
>         <dependency>
>             <groupId>com.vladmihalcea</groupId>
>             <artifactId>hibernate-types-52</artifactId>
>             <version>2.7.1</version>
>         </dependency>
>         <!-- unit testing -->
>         <dependency>
>             <groupId>org.junit.jupiter</groupId>
>             <artifactId>junit-jupiter-engine</artifactId>
>             <version>5.5.2</version>
>             <scope>test</scope>
>         </dependency>
>         <dependency>
>             <groupId>org.jboss.weld</groupId>
>             <artifactId>weld-junit5</artifactId>
>             <version>2.0.1.Final</version>
>             <scope>test</scope>
>         </dependency>
>         <dependency>
>             <groupId>org.mockito</groupId>
>             <artifactId>mockito-core</artifactId>
>             <version>3.1.0</version>
>             <scope>test</scope>
>         </dependency>
>         <!--<dependency>
>             <groupId>org.glassfish</groupId>
>             <artifactId>javax.json</artifactId>
>             <version>1.1</version>
>             <scope>test</scope>
>         </dependency>-->
>
>         <!-- integration testing -->
>
>         <dependency>
>             <groupId>junit</groupId>
>             <artifactId>junit</artifactId>
>             <version>4.12</version>
>             <scope>test</scope>
>         </dependency>
>
>         <dependency>
>             <groupId>org.jboss.arquillian.junit</groupId>
>             <artifactId>arquillian-junit-container</artifactId>
>             <version>1.5.0.Final</version>
>             <scope>test</scope>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apache.tomee</groupId>
>             <artifactId>arquillian-tomee-remote</artifactId>
>             <version>${tomee.version}</version>
>             <scope>test</scope>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apache.tomee</groupId>
>             <artifactId>apache-tomee</artifactId>
>             <version>${tomee.version}</version>
>             <classifier>plus</classifier>
>             <type>zip</type>
>             <scope>test</scope>
>         </dependency>
>
>         <dependency>
>             <groupId>org.jboss.shrinkwrap.resolver</groupId>
>             <artifactId>shrinkwrap-resolver-depchain</artifactId>
>             <version>3.1.3</version>
>             <scope>test</scope>
>             <type>pom</type>
>         </dependency>
>
>     </dependencies>
>
>     <build>
>         <plugins>
>             <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-compiler-plugin</artifactId>
>                 <version>3.1</version>
>                 <configuration>
>                     <source>1.8</source>
>                     <target>1.8</target>
>                     <compilerArguments>
>                         <endorseddirs>${endorsed.dir}</endorseddirs>
>                     </compilerArguments>
>                     <showDeprecation>true</showDeprecation>
>                 </configuration>
>             </plugin>
>             <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-war-plugin</artifactId>
>                 <version>2.3</version>
>                 <configuration>
>                     <failOnMissingWebXml>false</failOnMissingWebXml>
>                 </configuration>
>             </plugin>
>             <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-dependency-plugin</artifactId>
>                 <version>2.6</version>
>                 <executions>
>                     <execution>
>                         <phase>validate</phase>
>                         <goals>
>                             <goal>copy</goal>
>                         </goals>
>                         <configuration>
>
> <outputDirectory>${endorsed.dir}</outputDirectory>
>                             <silent>true</silent>
>                             <artifactItems>
>                                 <artifactItem>
>                                     <groupId>javax</groupId>
>
> <artifactId>javaee-endorsed-api</artifactId>
>                                     <version>7.0</version>
>                                     <type>jar</type>
>                                 </artifactItem>
>                             </artifactItems>
>                         </configuration>
>                     </execution>
>                 </executions>
>             </plugin>
>
>             <plugin>
>                 <groupId>org.apache.tomee.maven</groupId>
>                 <artifactId>tomee-maven-plugin</artifactId>
>                 <version>${tomee.version}</version>
>                 <configuration>
>                     <tomeeVersion>${tomee.version}</tomeeVersion>
>                     <tomeeClassifier>${tomee.classifier}</tomeeClassifier>
>                 </configuration>
>             </plugin>
>
>         </plugins>
>     </build>
> </project>
>
> Thank you!
>
> --
> With best regards,
> Alexey Makarov
>
>
Reply | Threaded
Open this post in threaded view
|

Re: TomEE and Arquillian

Makarov Alexey
Thank you, very match!
I have file arqullian.xml and "classifier" property already, but I forgot to surround content of file with "<arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">...</arquillian>". Sorry!
Now it works!

 --
 With best regards,
 Alexey Makarov

12.11.2019, 14:55, "Jonathan Gallimore" <[hidden email]>:

> You should be able to specify it using the "classifier" property in
> arquillian.xml:
>
> <arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
>   <container qualifier="tomee" default="true">
>     <configuration>
>       <property name="classifier">plus</property>
>       <property name="httpPort">-1</property>
>       <property name="stopPort">-1</property>
>       <property name="tomcatVersion"></property>
>       <property name="openejbVersion">${tomee.version}</property>
>       <property name="dir">target/apache-tomee-remote</property>
>       <property
> name="appWorkingDir">target/arquillian-test-working-dir</property>
>     </configuration>
>   </container>
> </arquillian>
>
> Let us know how you get on!
>
> Jon
>
> On Tue, Nov 12, 2019 at 11:30 AM Makarov Alexey <[hidden email]> wrote:
>
>>  Hello!
>>  I use "TomEE 8 plus", and I want to write integration tests.
>>  I wrote small test and set some config in pom.xml. When I start tests and
>>  look at console I see:
>>  "INFO: Downloading org.apache.tomee:apache-tomee:8.0.0:zip:webprofile
>>  please wait...",- my maven download webprofile, I use ActiveMQ and as far
>>  as I understand, I need plus or plume profile. How I can do this?
>>
>>  My pom.xml:
>>
>>  <?xml version="1.0" encoding="UTF-8"?>
>>  <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
>>  http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="
>>  http://maven.apache.org/POM/4.0.0
>>  http://maven.apache.org/xsd/maven-4.0.0.xsd">
>>      <modelVersion>4.0.0</modelVersion>
>>
>>      <groupId>ru.ritos</groupId>
>>      <artifactId>ritos-backend</artifactId>
>>      <version>1.0-SNAPSHOT</version>
>>      <packaging>war</packaging>
>>
>>      <name>ritos-backend</name>
>>
>>      <properties>
>>          <endorsed.dir>${project.build.directory}/endorsed</endorsed.dir>
>>          <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
>>          <deltaspike.version>1.9.1</deltaspike.version>
>>          <tomee.version>8.0.0</tomee.version>
>>          <tomee.classifier>plus</tomee.classifier>
>>      </properties>
>>
>>      <dependencyManagement>
>>          <dependencies>
>>              <dependency>
>>                  <groupId>org.apache.deltaspike.distribution</groupId>
>>                  <artifactId>distributions-bom</artifactId>
>>                  <version>${deltaspike.version}</version>
>>                  <type>pom</type>
>>                  <scope>import</scope>
>>              </dependency>
>>              <dependency>
>>                  <groupId>org.jboss.arquillian</groupId>
>>                  <artifactId>arquillian-bom</artifactId>
>>                  <version>1.5.0.Final</version>
>>                  <scope>import</scope>
>>                  <type>pom</type>
>>              </dependency>
>>          </dependencies>
>>      </dependencyManagement>
>>
>>      <dependencies>
>>          <dependency>
>>              <groupId>redis.clients</groupId>
>>              <artifactId>jedis</artifactId>
>>              <version>3.1.0</version>
>>          </dependency>
>>          <dependency>
>>              <groupId>commons-codec</groupId>
>>              <artifactId>commons-codec</artifactId>
>>              <version>1.13</version>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.apache.commons</groupId>
>>              <artifactId>commons-lang3</artifactId>
>>              <version>3.9</version>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.apache.httpcomponents</groupId>
>>              <artifactId>httpclient</artifactId>
>>              <version>4.5.10</version>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.postgresql</groupId>
>>              <artifactId>postgresql</artifactId>
>>              <version>42.2.8</version>
>>          </dependency>
>>          <dependency>
>>              <groupId>javax</groupId>
>>              <artifactId>javaee-api</artifactId>
>>              <version>8.0</version>
>>              <scope>provided</scope>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.apache.deltaspike.core</groupId>
>>              <artifactId>deltaspike-core-api</artifactId>
>>              <scope>compile</scope>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.apache.deltaspike.core</groupId>
>>              <artifactId>deltaspike-core-impl</artifactId>
>>              <scope>runtime</scope>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.apache.deltaspike.modules</groupId>
>>              <artifactId>deltaspike-security-module-api</artifactId>
>>              <scope>compile</scope>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.apache.deltaspike.modules</groupId>
>>              <artifactId>deltaspike-security-module-impl</artifactId>
>>              <scope>runtime</scope>
>>          </dependency>
>>          <!-- Hibernate -->
>>          <dependency>
>>              <groupId>org.hibernate</groupId>
>>              <artifactId>hibernate-entitymanager</artifactId>
>>              <version>5.3.13.Final</version>
>>          </dependency>
>>
>>          <dependency>
>>              <groupId>com.vladmihalcea</groupId>
>>              <artifactId>hibernate-types-52</artifactId>
>>              <version>2.7.1</version>
>>          </dependency>
>>          <!-- unit testing -->
>>          <dependency>
>>              <groupId>org.junit.jupiter</groupId>
>>              <artifactId>junit-jupiter-engine</artifactId>
>>              <version>5.5.2</version>
>>              <scope>test</scope>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.jboss.weld</groupId>
>>              <artifactId>weld-junit5</artifactId>
>>              <version>2.0.1.Final</version>
>>              <scope>test</scope>
>>          </dependency>
>>          <dependency>
>>              <groupId>org.mockito</groupId>
>>              <artifactId>mockito-core</artifactId>
>>              <version>3.1.0</version>
>>              <scope>test</scope>
>>          </dependency>
>>          <!--<dependency>
>>              <groupId>org.glassfish</groupId>
>>              <artifactId>javax.json</artifactId>
>>              <version>1.1</version>
>>              <scope>test</scope>
>>          </dependency>-->
>>
>>          <!-- integration testing -->
>>
>>          <dependency>
>>              <groupId>junit</groupId>
>>              <artifactId>junit</artifactId>
>>              <version>4.12</version>
>>              <scope>test</scope>
>>          </dependency>
>>
>>          <dependency>
>>              <groupId>org.jboss.arquillian.junit</groupId>
>>              <artifactId>arquillian-junit-container</artifactId>
>>              <version>1.5.0.Final</version>
>>              <scope>test</scope>
>>          </dependency>
>>
>>          <dependency>
>>              <groupId>org.apache.tomee</groupId>
>>              <artifactId>arquillian-tomee-remote</artifactId>
>>              <version>${tomee.version}</version>
>>              <scope>test</scope>
>>          </dependency>
>>
>>          <dependency>
>>              <groupId>org.apache.tomee</groupId>
>>              <artifactId>apache-tomee</artifactId>
>>              <version>${tomee.version}</version>
>>              <classifier>plus</classifier>
>>              <type>zip</type>
>>              <scope>test</scope>
>>          </dependency>
>>
>>          <dependency>
>>              <groupId>org.jboss.shrinkwrap.resolver</groupId>
>>              <artifactId>shrinkwrap-resolver-depchain</artifactId>
>>              <version>3.1.3</version>
>>              <scope>test</scope>
>>              <type>pom</type>
>>          </dependency>
>>
>>      </dependencies>
>>
>>      <build>
>>          <plugins>
>>              <plugin>
>>                  <groupId>org.apache.maven.plugins</groupId>
>>                  <artifactId>maven-compiler-plugin</artifactId>
>>                  <version>3.1</version>
>>                  <configuration>
>>                      <source>1.8</source>
>>                      <target>1.8</target>
>>                      <compilerArguments>
>>                          <endorseddirs>${endorsed.dir}</endorseddirs>
>>                      </compilerArguments>
>>                      <showDeprecation>true</showDeprecation>
>>                  </configuration>
>>              </plugin>
>>              <plugin>
>>                  <groupId>org.apache.maven.plugins</groupId>
>>                  <artifactId>maven-war-plugin</artifactId>
>>                  <version>2.3</version>
>>                  <configuration>
>>                      <failOnMissingWebXml>false</failOnMissingWebXml>
>>                  </configuration>
>>              </plugin>
>>              <plugin>
>>                  <groupId>org.apache.maven.plugins</groupId>
>>                  <artifactId>maven-dependency-plugin</artifactId>
>>                  <version>2.6</version>
>>                  <executions>
>>                      <execution>
>>                          <phase>validate</phase>
>>                          <goals>
>>                              <goal>copy</goal>
>>                          </goals>
>>                          <configuration>
>>
>>  <outputDirectory>${endorsed.dir}</outputDirectory>
>>                              <silent>true</silent>
>>                              <artifactItems>
>>                                  <artifactItem>
>>                                      <groupId>javax</groupId>
>>
>>  <artifactId>javaee-endorsed-api</artifactId>
>>                                      <version>7.0</version>
>>                                      <type>jar</type>
>>                                  </artifactItem>
>>                              </artifactItems>
>>                          </configuration>
>>                      </execution>
>>                  </executions>
>>              </plugin>
>>
>>              <plugin>
>>                  <groupId>org.apache.tomee.maven</groupId>
>>                  <artifactId>tomee-maven-plugin</artifactId>
>>                  <version>${tomee.version}</version>
>>                  <configuration>
>>                      <tomeeVersion>${tomee.version}</tomeeVersion>
>>                      <tomeeClassifier>${tomee.classifier}</tomeeClassifier>
>>                  </configuration>
>>              </plugin>
>>
>>          </plugins>
>>      </build>
>>  </project>
>>
>>  Thank you!
>>
>>  --
>>  With best regards,
>>  Alexey Makarov
Reply | Threaded
Open this post in threaded view
|

Re: TomEE and Arquillian

jgallimore
That's awesome, thanks for the follow up!

Jon

On Tue, Nov 12, 2019 at 1:59 PM Makarov Alexey <[hidden email]> wrote:

> Thank you, very match!
> I have file arqullian.xml and "classifier" property already, but I forgot
> to surround content of file with "<arquillian xmlns:xsi="
> http://www.w3.org/2001/XMLSchema-instance">...</arquillian>". Sorry!
> Now it works!
>
>  --
>  With best regards,
>  Alexey Makarov
>
> 12.11.2019, 14:55, "Jonathan Gallimore" <[hidden email]>:
> > You should be able to specify it using the "classifier" property in
> > arquillian.xml:
> >
> > <arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
> >   <container qualifier="tomee" default="true">
> >     <configuration>
> >       <property name="classifier">plus</property>
> >       <property name="httpPort">-1</property>
> >       <property name="stopPort">-1</property>
> >       <property name="tomcatVersion"></property>
> >       <property name="openejbVersion">${tomee.version}</property>
> >       <property name="dir">target/apache-tomee-remote</property>
> >       <property
> > name="appWorkingDir">target/arquillian-test-working-dir</property>
> >     </configuration>
> >   </container>
> > </arquillian>
> >
> > Let us know how you get on!
> >
> > Jon
> >
> > On Tue, Nov 12, 2019 at 11:30 AM Makarov Alexey <[hidden email]>
> wrote:
> >
> >>  Hello!
> >>  I use "TomEE 8 plus", and I want to write integration tests.
> >>  I wrote small test and set some config in pom.xml. When I start tests
> and
> >>  look at console I see:
> >>  "INFO: Downloading org.apache.tomee:apache-tomee:8.0.0:zip:webprofile
> >>  please wait...",- my maven download webprofile, I use ActiveMQ and as
> far
> >>  as I understand, I need plus or plume profile. How I can do this?
> >>
> >>  My pom.xml:
> >>
> >>  <?xml version="1.0" encoding="UTF-8"?>
> >>  <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
> >>  http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="
> >>  http://maven.apache.org/POM/4.0.0
> >>  http://maven.apache.org/xsd/maven-4.0.0.xsd">
> >>      <modelVersion>4.0.0</modelVersion>
> >>
> >>      <groupId>ru.ritos</groupId>
> >>      <artifactId>ritos-backend</artifactId>
> >>      <version>1.0-SNAPSHOT</version>
> >>      <packaging>war</packaging>
> >>
> >>      <name>ritos-backend</name>
> >>
> >>      <properties>
> >>
>          <endorsed.dir>${project.build.directory}/endorsed</endorsed.dir>
> >>
>          <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
> >>          <deltaspike.version>1.9.1</deltaspike.version>
> >>          <tomee.version>8.0.0</tomee.version>
> >>          <tomee.classifier>plus</tomee.classifier>
> >>      </properties>
> >>
> >>      <dependencyManagement>
> >>          <dependencies>
> >>              <dependency>
> >>                  <groupId>org.apache.deltaspike.distribution</groupId>
> >>                  <artifactId>distributions-bom</artifactId>
> >>                  <version>${deltaspike.version}</version>
> >>                  <type>pom</type>
> >>                  <scope>import</scope>
> >>              </dependency>
> >>              <dependency>
> >>                  <groupId>org.jboss.arquillian</groupId>
> >>                  <artifactId>arquillian-bom</artifactId>
> >>                  <version>1.5.0.Final</version>
> >>                  <scope>import</scope>
> >>                  <type>pom</type>
> >>              </dependency>
> >>          </dependencies>
> >>      </dependencyManagement>
> >>
> >>      <dependencies>
> >>          <dependency>
> >>              <groupId>redis.clients</groupId>
> >>              <artifactId>jedis</artifactId>
> >>              <version>3.1.0</version>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>commons-codec</groupId>
> >>              <artifactId>commons-codec</artifactId>
> >>              <version>1.13</version>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.apache.commons</groupId>
> >>              <artifactId>commons-lang3</artifactId>
> >>              <version>3.9</version>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.apache.httpcomponents</groupId>
> >>              <artifactId>httpclient</artifactId>
> >>              <version>4.5.10</version>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.postgresql</groupId>
> >>              <artifactId>postgresql</artifactId>
> >>              <version>42.2.8</version>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>javax</groupId>
> >>              <artifactId>javaee-api</artifactId>
> >>              <version>8.0</version>
> >>              <scope>provided</scope>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.apache.deltaspike.core</groupId>
> >>              <artifactId>deltaspike-core-api</artifactId>
> >>              <scope>compile</scope>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.apache.deltaspike.core</groupId>
> >>              <artifactId>deltaspike-core-impl</artifactId>
> >>              <scope>runtime</scope>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.apache.deltaspike.modules</groupId>
> >>              <artifactId>deltaspike-security-module-api</artifactId>
> >>              <scope>compile</scope>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.apache.deltaspike.modules</groupId>
> >>              <artifactId>deltaspike-security-module-impl</artifactId>
> >>              <scope>runtime</scope>
> >>          </dependency>
> >>          <!-- Hibernate -->
> >>          <dependency>
> >>              <groupId>org.hibernate</groupId>
> >>              <artifactId>hibernate-entitymanager</artifactId>
> >>              <version>5.3.13.Final</version>
> >>          </dependency>
> >>
> >>          <dependency>
> >>              <groupId>com.vladmihalcea</groupId>
> >>              <artifactId>hibernate-types-52</artifactId>
> >>              <version>2.7.1</version>
> >>          </dependency>
> >>          <!-- unit testing -->
> >>          <dependency>
> >>              <groupId>org.junit.jupiter</groupId>
> >>              <artifactId>junit-jupiter-engine</artifactId>
> >>              <version>5.5.2</version>
> >>              <scope>test</scope>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.jboss.weld</groupId>
> >>              <artifactId>weld-junit5</artifactId>
> >>              <version>2.0.1.Final</version>
> >>              <scope>test</scope>
> >>          </dependency>
> >>          <dependency>
> >>              <groupId>org.mockito</groupId>
> >>              <artifactId>mockito-core</artifactId>
> >>              <version>3.1.0</version>
> >>              <scope>test</scope>
> >>          </dependency>
> >>          <!--<dependency>
> >>              <groupId>org.glassfish</groupId>
> >>              <artifactId>javax.json</artifactId>
> >>              <version>1.1</version>
> >>              <scope>test</scope>
> >>          </dependency>-->
> >>
> >>          <!-- integration testing -->
> >>
> >>          <dependency>
> >>              <groupId>junit</groupId>
> >>              <artifactId>junit</artifactId>
> >>              <version>4.12</version>
> >>              <scope>test</scope>
> >>          </dependency>
> >>
> >>          <dependency>
> >>              <groupId>org.jboss.arquillian.junit</groupId>
> >>              <artifactId>arquillian-junit-container</artifactId>
> >>              <version>1.5.0.Final</version>
> >>              <scope>test</scope>
> >>          </dependency>
> >>
> >>          <dependency>
> >>              <groupId>org.apache.tomee</groupId>
> >>              <artifactId>arquillian-tomee-remote</artifactId>
> >>              <version>${tomee.version}</version>
> >>              <scope>test</scope>
> >>          </dependency>
> >>
> >>          <dependency>
> >>              <groupId>org.apache.tomee</groupId>
> >>              <artifactId>apache-tomee</artifactId>
> >>              <version>${tomee.version}</version>
> >>              <classifier>plus</classifier>
> >>              <type>zip</type>
> >>              <scope>test</scope>
> >>          </dependency>
> >>
> >>          <dependency>
> >>              <groupId>org.jboss.shrinkwrap.resolver</groupId>
> >>              <artifactId>shrinkwrap-resolver-depchain</artifactId>
> >>              <version>3.1.3</version>
> >>              <scope>test</scope>
> >>              <type>pom</type>
> >>          </dependency>
> >>
> >>      </dependencies>
> >>
> >>      <build>
> >>          <plugins>
> >>              <plugin>
> >>                  <groupId>org.apache.maven.plugins</groupId>
> >>                  <artifactId>maven-compiler-plugin</artifactId>
> >>                  <version>3.1</version>
> >>                  <configuration>
> >>                      <source>1.8</source>
> >>                      <target>1.8</target>
> >>                      <compilerArguments>
> >>                          <endorseddirs>${endorsed.dir}</endorseddirs>
> >>                      </compilerArguments>
> >>                      <showDeprecation>true</showDeprecation>
> >>                  </configuration>
> >>              </plugin>
> >>              <plugin>
> >>                  <groupId>org.apache.maven.plugins</groupId>
> >>                  <artifactId>maven-war-plugin</artifactId>
> >>                  <version>2.3</version>
> >>                  <configuration>
> >>                      <failOnMissingWebXml>false</failOnMissingWebXml>
> >>                  </configuration>
> >>              </plugin>
> >>              <plugin>
> >>                  <groupId>org.apache.maven.plugins</groupId>
> >>                  <artifactId>maven-dependency-plugin</artifactId>
> >>                  <version>2.6</version>
> >>                  <executions>
> >>                      <execution>
> >>                          <phase>validate</phase>
> >>                          <goals>
> >>                              <goal>copy</goal>
> >>                          </goals>
> >>                          <configuration>
> >>
> >>  <outputDirectory>${endorsed.dir}</outputDirectory>
> >>                              <silent>true</silent>
> >>                              <artifactItems>
> >>                                  <artifactItem>
> >>                                      <groupId>javax</groupId>
> >>
> >>  <artifactId>javaee-endorsed-api</artifactId>
> >>                                      <version>7.0</version>
> >>                                      <type>jar</type>
> >>                                  </artifactItem>
> >>                              </artifactItems>
> >>                          </configuration>
> >>                      </execution>
> >>                  </executions>
> >>              </plugin>
> >>
> >>              <plugin>
> >>                  <groupId>org.apache.tomee.maven</groupId>
> >>                  <artifactId>tomee-maven-plugin</artifactId>
> >>                  <version>${tomee.version}</version>
> >>                  <configuration>
> >>                      <tomeeVersion>${tomee.version}</tomeeVersion>
> >>
>                      <tomeeClassifier>${tomee.classifier}</tomeeClassifier>
> >>                  </configuration>
> >>              </plugin>
> >>
> >>          </plugins>
> >>      </build>
> >>  </project>
> >>
> >>  Thank you!
> >>
> >>  --
> >>  With best regards,
> >>  Alexey Makarov
>