Outdated TomEE and Arquillian (with regard to TomEE 7)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Outdated TomEE and Arquillian (with regard to TomEE 7)

Alex The Rocker
Hello,

I was training myself on Arquilian, with the hope to use it test our
apps' REST annotations in the context of actual TomEE+ behavior (in
particular, I'd like to use it to check whether or not newer TomEE+
version don't leak to issues with regard to these sensitive items,
migration from 1.7.x to 7.0.x wasn't transparent with Johnzon new
annots).

So, I googled "tomee arqulian", and I got the following page:
http://tomee.apache.org/arquillian-available-adapters.html

Since I before went through Arquilan's getting started pages, I
directly jumped to adding TomEE embedded as a profile into the
samples' pom, using a copy past of what's proposed on this page

  <profile>
    <id>tomee-embedded</id>
    <activation>
      <activeByDefault>true</activeByDefault>
    </activation>
    <dependencies>
      <dependency>
        <groupId>org.apache.openejb</groupId>
        <artifactId>arquillian-tomee-embedded</artifactId>
        <version>1.0.0</version>
      </dependency>
    </dependencies>
  </profile>

It worked, but then I wanted to try with latest TomEE+ 7.0.3, so I
changed this into:

  <profile>
    <id>tomee-embedded</id>
    <activation>
      <activeByDefault>true</activeByDefault>
    </activation>
    <dependencies>
      <dependency>
        <groupId>org.apache.openejb</groupId>
        <artifactId>arquillian-tomee-embedded</artifactId>
        <version>7.0.3</version>
      </dependency>
    </dependencies>
  </profile>

and I got the following error from Eclipse on the pom file:

Missing artifact
org.apache.openejb:arquillian-tomee-embedded:jar:7.0.3    pom.xml
/arquillian-tutorial

After a while, I finally found that changing org.apache.openejb into
org.apache.tomee in the groupId solved the issue, so here's the
correction version:

  <profile>
    <id>tomee-embedded</id>
    <activation>
      <activeByDefault>true</activeByDefault>
    </activation>
    <dependencies>
      <dependency>
        <groupId>org.apache.tomee</groupId>
        <artifactId>arquillian-tomee-embedded</artifactId>
        <version>7.0.3</version>
      </dependency>
    </dependencies>
  </profile>


Would it be possible to fix
http://tomee.apache.org/arquillian-available-adapters.html page in
order to avoid newbies to get lost with Arquilan with TomEE 7 testing?


Best regards,
Alexandre
Reply | Threaded
Open this post in threaded view
|

Re: Outdated TomEE and Arquillian (with regard to TomEE 7)

Romain Manni-Bucau
Hi Alex,

actual doc is at
http://tomee.apache.org/developer/testing/arquillian/index.html

the one you mentionned was kept to not break bookmarks but is no more
maintained - no link from the main website.

Google probably didn't do its job yet ;)


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://rmannibucau.metawerx.net/> | Old Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau>

2017-10-08 10:39 GMT+02:00 Alex The Rocker <[hidden email]>:

> Hello,
>
> I was training myself on Arquilian, with the hope to use it test our
> apps' REST annotations in the context of actual TomEE+ behavior (in
> particular, I'd like to use it to check whether or not newer TomEE+
> version don't leak to issues with regard to these sensitive items,
> migration from 1.7.x to 7.0.x wasn't transparent with Johnzon new
> annots).
>
> So, I googled "tomee arqulian", and I got the following page:
> http://tomee.apache.org/arquillian-available-adapters.html
>
> Since I before went through Arquilan's getting started pages, I
> directly jumped to adding TomEE embedded as a profile into the
> samples' pom, using a copy past of what's proposed on this page
>
>   <profile>
>     <id>tomee-embedded</id>
>     <activation>
>       <activeByDefault>true</activeByDefault>
>     </activation>
>     <dependencies>
>       <dependency>
>         <groupId>org.apache.openejb</groupId>
>         <artifactId>arquillian-tomee-embedded</artifactId>
>         <version>1.0.0</version>
>       </dependency>
>     </dependencies>
>   </profile>
>
> It worked, but then I wanted to try with latest TomEE+ 7.0.3, so I
> changed this into:
>
>   <profile>
>     <id>tomee-embedded</id>
>     <activation>
>       <activeByDefault>true</activeByDefault>
>     </activation>
>     <dependencies>
>       <dependency>
>         <groupId>org.apache.openejb</groupId>
>         <artifactId>arquillian-tomee-embedded</artifactId>
>         <version>7.0.3</version>
>       </dependency>
>     </dependencies>
>   </profile>
>
> and I got the following error from Eclipse on the pom file:
>
> Missing artifact
> org.apache.openejb:arquillian-tomee-embedded:jar:7.0.3    pom.xml
> /arquillian-tutorial
>
> After a while, I finally found that changing org.apache.openejb into
> org.apache.tomee in the groupId solved the issue, so here's the
> correction version:
>
>   <profile>
>     <id>tomee-embedded</id>
>     <activation>
>       <activeByDefault>true</activeByDefault>
>     </activation>
>     <dependencies>
>       <dependency>
>         <groupId>org.apache.tomee</groupId>
>         <artifactId>arquillian-tomee-embedded</artifactId>
>         <version>7.0.3</version>
>       </dependency>
>     </dependencies>
>   </profile>
>
>
> Would it be possible to fix
> http://tomee.apache.org/arquillian-available-adapters.html page in
> order to avoid newbies to get lost with Arquilan with TomEE 7 testing?
>
>
> Best regards,
> Alexandre
>