Missing xalan library in TomEE 7.0.7 and 7.0.8

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing xalan library in TomEE 7.0.7 and 7.0.8

lazarkirchev
Hello,

About three years ago, xalan library was added to TomEE following
https://issues.apache.org/jira/browse/TOMEE-2113

Now in TomEE 7.0.7 this library was removed with
https://github.com/apache/tomee/commit/8ab6bb2fb78dd8818c8b330a16687015f4719c5e
although the apache taglibs.* 1.2.5 are still used.

Now the same problem described in TOMEE-2113 appears again.

Why xalan was removed in 7.0.7 and do you have plans to include it again?

Regards,
Lazar
Reply | Threaded
Open this post in threaded view
|

Re: Missing xalan library in TomEE 7.0.7 and 7.0.8

jgallimore
The reason for its removal is that there are some bugs with Xalan's unicode
handling, and this library hasn't seen an update for 6 years. I wasn't
aware of the regression at the time, so thank you for flagging that up.

I think my preference would be to look at how we can resolve the issue
without pulling these dependencies back in - I'll take a look at how we do
that.

Jon

On Mon, Oct 5, 2020 at 9:00 AM Lazar Kirchev <[hidden email]>
wrote:

> Hello,
>
> About three years ago, xalan library was added to TomEE following
> https://issues.apache.org/jira/browse/TOMEE-2113
>
> Now in TomEE 7.0.7 this library was removed with
>
> https://github.com/apache/tomee/commit/8ab6bb2fb78dd8818c8b330a16687015f4719c5e
> although the apache taglibs.* 1.2.5 are still used.
>
> Now the same problem described in TOMEE-2113 appears again.
>
> Why xalan was removed in 7.0.7 and do you have plans to include it again?
>
> Regards,
> Lazar
>