MP.next()

classic Classic list List threaded Threaded
26 messages Options
12
Reply | Threaded
Open this post in threaded view
|

MP.next()

Jean-Louis MONTEIRO
Hi community,

Most microprofile requires Java 8.
Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?

Thanks


--
Jean-Louis Monteiro
http://twitter.com/jlouismonteiro
http://www.tomitribe.com
   --
    Jean-Louis Monteiro
    http://twitter.com/jlouismonteiro
    http://www.tomitribe.com
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Romain Manni-Bucau
Isnt it fb_tomee8 branch so tomee 8?

Otherwise +1

Le 17 avr. 2018 01:11, "Jean-Louis Monteiro" <[hidden email]> a
écrit :

> Hi community,
>
> Most microprofile requires Java 8.
> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>
> Thanks
>
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com
>
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

AndyG
In reply to this post by Jean-Louis MONTEIRO
+1

Andy Gumbrecht


On 04/17/2018 01:11 AM, Jean-Louis Monteiro wrote:

> Hi community,
>
> Most microprofile requires Java 8.
> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>
> Thanks
>
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com
>

Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

jgallimore
In reply to this post by Jean-Louis MONTEIRO
+1

On Tue, Apr 17, 2018 at 12:11 AM, Jean-Louis Monteiro <
[hidden email]> wrote:

> Hi community,
>
> Most microprofile requires Java 8.
> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>
> Thanks
>
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com
>
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Roberto Cortez
In reply to this post by Jean-Louis MONTEIRO
 
+1    On Tuesday, April 17, 2018, 12:11:58 AM GMT+1, Jean-Louis Monteiro <[hidden email]> wrote:  
 
 Hi community,

Most microprofile requires Java 8.
Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?

Thanks


--
Jean-Louis Monteiro
http://twitter.com/jlouismonteiro
http://www.tomitribe.com
 
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Rudy De Busscher
+1 (Non binding)

Rudy

On 17 April 2018 at 13:12, Roberto Cortez <[hidden email]>
wrote:

>
> +1    On Tuesday, April 17, 2018, 12:11:58 AM GMT+1, Jean-Louis Monteiro <
> [hidden email]> wrote:
>
>  Hi community,
>
> Most microprofile requires Java 8.
> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>
> Thanks
>
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com
>
>
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Richard Monson-Haefel
In reply to this post by Jean-Louis MONTEIRO
+1

On Mon, Apr 16, 2018 at 6:11 PM Jean-Louis Monteiro <
[hidden email]> wrote:

> Hi community,
>
> Most microprofile requires Java 8.
> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>
> Thanks
>
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com
>
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

David Blevins-2
In reply to this post by Jean-Louis MONTEIRO
+1


--
David Blevins
http://twitter.com/dblevins
http://www.tomitribe.com

> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <[hidden email]> wrote:
>
> Hi community,
>
> Most microprofile requires Java 8.
> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>
> Thanks
>
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com

Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Jean-Louis MONTEIRO
Thanks guys.
Yes I meant TomEE 8.x

I have rework the MP-JWT contribution so the extension leaves into a
different module than the TCK.
The TCK is green for the MP-JWT.

New PR is here https://github.com/apache/tomee/pull/130
If you are ok, I will revert from current master the MP-JWT which requires
Java 8 and is therefor incompatible with TomEE 7.x

On the TomEE 8.x branch, I'll create an example and push to the same PR.



--
Jean-Louis Monteiro
http://twitter.com/jlouismonteiro
http://www.tomitribe.com

On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <[hidden email]>
wrote:

> +1
>
>
> --
> David Blevins
> http://twitter.com/dblevins
> http://www.tomitribe.com
>
> > On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
> [hidden email]> wrote:
> >
> > Hi community,
> >
> > Most microprofile requires Java 8.
> > Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
> >
> > Thanks
> >
> >
> > --
> > Jean-Louis Monteiro
> > http://twitter.com/jlouismonteiro
> > http://www.tomitribe.com
>
>
   --
    Jean-Louis Monteiro
    http://twitter.com/jlouismonteiro
    http://www.tomitribe.com
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

David Blevins-2
Can we also create a TomEE 7.1?  I think everyone who +1ed was thinking about something we could release sooner than TomEE 8.x.


--
David Blevins
http://twitter.com/dblevins
http://www.tomitribe.com

> On Apr 17, 2018, at 1:55 PM, Jean-Louis Monteiro <[hidden email]> wrote:
>
> Thanks guys.
> Yes I meant TomEE 8.x
>
> I have rework the MP-JWT contribution so the extension leaves into a
> different module than the TCK.
> The TCK is green for the MP-JWT.
>
> New PR is here https://github.com/apache/tomee/pull/130
> If you are ok, I will revert from current master the MP-JWT which requires
> Java 8 and is therefor incompatible with TomEE 7.x
>
> On the TomEE 8.x branch, I'll create an example and push to the same PR.
>
>
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com
>
> On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <[hidden email]>
> wrote:
>
>> +1
>>
>>
>> --
>> David Blevins
>> http://twitter.com/dblevins
>> http://www.tomitribe.com
>>
>>> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
>> [hidden email]> wrote:
>>>
>>> Hi community,
>>>
>>> Most microprofile requires Java 8.
>>> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>>>
>>> Thanks
>>>
>>>
>>> --
>>> Jean-Louis Monteiro
>>> http://twitter.com/jlouismonteiro
>>> http://www.tomitribe.com
>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Jean-Louis MONTEIRO
Do we have a branch for it?
Master is 7.x for Java 7



--
Jean-Louis Monteiro
http://twitter.com/jlouismonteiro
http://www.tomitribe.com

On Tue, Apr 17, 2018 at 11:25 PM, David Blevins <[hidden email]>
wrote:

> Can we also create a TomEE 7.1?  I think everyone who +1ed was thinking
> about something we could release sooner than TomEE 8.x.
>
>
> --
> David Blevins
> http://twitter.com/dblevins
> http://www.tomitribe.com
>
> > On Apr 17, 2018, at 1:55 PM, Jean-Louis Monteiro <
> [hidden email]> wrote:
> >
> > Thanks guys.
> > Yes I meant TomEE 8.x
> >
> > I have rework the MP-JWT contribution so the extension leaves into a
> > different module than the TCK.
> > The TCK is green for the MP-JWT.
> >
> > New PR is here https://github.com/apache/tomee/pull/130
> > If you are ok, I will revert from current master the MP-JWT which
> requires
> > Java 8 and is therefor incompatible with TomEE 7.x
> >
> > On the TomEE 8.x branch, I'll create an example and push to the same PR.
> >
> >
> >
> > --
> > Jean-Louis Monteiro
> > http://twitter.com/jlouismonteiro
> > http://www.tomitribe.com
> >
> > On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <[hidden email]>
> > wrote:
> >
> >> +1
> >>
> >>
> >> --
> >> David Blevins
> >> http://twitter.com/dblevins
> >> http://www.tomitribe.com
> >>
> >>> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
> >> [hidden email]> wrote:
> >>>
> >>> Hi community,
> >>>
> >>> Most microprofile requires Java 8.
> >>> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java
> 8)?
> >>>
> >>> Thanks
> >>>
> >>>
> >>> --
> >>> Jean-Louis Monteiro
> >>> http://twitter.com/jlouismonteiro
> >>> http://www.tomitribe.com
> >>
> >>
>
>
   --
    Jean-Louis Monteiro
    http://twitter.com/jlouismonteiro
    http://www.tomitribe.com
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

David Blevins-2
In reply to this post by David Blevins-2

> On Apr 17, 2018, at 2:25 PM, David Blevins <[hidden email]> wrote:
>
> Can we also create a TomEE 7.1?  I think everyone who +1ed was thinking about something we could release sooner than TomEE 8.x.

Never mind, I see you have two PRs, one for 8.0 and one for a 7.1.  Never mind!

 - 7.1 https://github.com/apache/tomee/pull/125
 - 8.0 https://github.com/apache/tomee/pull/130

Looks good.


-David


>
>
> --
> David Blevins
> http://twitter.com/dblevins
> http://www.tomitribe.com
>
>> On Apr 17, 2018, at 1:55 PM, Jean-Louis Monteiro <[hidden email]> wrote:
>>
>> Thanks guys.
>> Yes I meant TomEE 8.x
>>
>> I have rework the MP-JWT contribution so the extension leaves into a
>> different module than the TCK.
>> The TCK is green for the MP-JWT.
>>
>> New PR is here https://github.com/apache/tomee/pull/130
>> If you are ok, I will revert from current master the MP-JWT which requires
>> Java 8 and is therefor incompatible with TomEE 7.x
>>
>> On the TomEE 8.x branch, I'll create an example and push to the same PR.
>>
>>
>>
>> --
>> Jean-Louis Monteiro
>> http://twitter.com/jlouismonteiro
>> http://www.tomitribe.com
>>
>> On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <[hidden email]>
>> wrote:
>>
>>> +1
>>>
>>>
>>> --
>>> David Blevins
>>> http://twitter.com/dblevins
>>> http://www.tomitribe.com
>>>
>>>> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
>>> [hidden email]> wrote:
>>>>
>>>> Hi community,
>>>>
>>>> Most microprofile requires Java 8.
>>>> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java 8)?
>>>>
>>>> Thanks
>>>>
>>>>
>>>> --
>>>> Jean-Louis Monteiro
>>>> http://twitter.com/jlouismonteiro
>>>> http://www.tomitribe.com
>>>
>>>
>

Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

David Blevins-2
In reply to this post by Jean-Louis MONTEIRO
> On Apr 17, 2018, at 2:26 PM, Jean-Louis Monteiro <[hidden email]> wrote:
>
> Do we have a branch for it?
> Master is 7.x for Java 7

Not sure how we want to run that.  One option is we could just switch wherever 7x lives now to 7.1.

If we really wanted to patch 7.0.x we could make a 7.0.x branch.

Jon, I know you're doing a lot of Java 9 & 10 work.  Would you want to do that in both a 7.1 and a 7.0.x or just a 7.1?

Certainly from a release announcement perspective, "TomEE 7.1 released with MicroProfile and Java 10 support" is pretty catchy.


Preferences?


-David

>
> On Tue, Apr 17, 2018 at 11:25 PM, David Blevins <[hidden email]>
> wrote:
>
>> Can we also create a TomEE 7.1?  I think everyone who +1ed was thinking
>> about something we could release sooner than TomEE 8.x.
>>
>>
>> --
>> David Blevins
>> http://twitter.com/dblevins
>> http://www.tomitribe.com
>>
>>> On Apr 17, 2018, at 1:55 PM, Jean-Louis Monteiro <
>> [hidden email]> wrote:
>>>
>>> Thanks guys.
>>> Yes I meant TomEE 8.x
>>>
>>> I have rework the MP-JWT contribution so the extension leaves into a
>>> different module than the TCK.
>>> The TCK is green for the MP-JWT.
>>>
>>> New PR is here https://github.com/apache/tomee/pull/130
>>> If you are ok, I will revert from current master the MP-JWT which
>> requires
>>> Java 8 and is therefor incompatible with TomEE 7.x
>>>
>>> On the TomEE 8.x branch, I'll create an example and push to the same PR.
>>>
>>>
>>>
>>> --
>>> Jean-Louis Monteiro
>>> http://twitter.com/jlouismonteiro
>>> http://www.tomitribe.com
>>>
>>> On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <[hidden email]>
>>> wrote:
>>>
>>>> +1
>>>>
>>>>
>>>> --
>>>> David Blevins
>>>> http://twitter.com/dblevins
>>>> http://www.tomitribe.com
>>>>
>>>>> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
>>>> [hidden email]> wrote:
>>>>>
>>>>> Hi community,
>>>>>
>>>>> Most microprofile requires Java 8.
>>>>> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java
>> 8)?
>>>>>
>>>>> Thanks
>>>>>
>>>>>
>>>>> --
>>>>> Jean-Louis Monteiro
>>>>> http://twitter.com/jlouismonteiro
>>>>> http://www.tomitribe.com
>>>>
>>>>
>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

jgallimore
On Tue, 17 Apr 2018, 22:32 David Blevins, <[hidden email]> wrote:

> > On Apr 17, 2018, at 2:26 PM, Jean-Louis Monteiro <
> [hidden email]> wrote:
> >
> > Do we have a branch for it?
> > Master is 7.x for Java 7
>
> Not sure how we want to run that.  One option is we could just switch
> wherever 7x lives now to 7.1.
>
> If we really wanted to patch 7.0.x we could make a 7.0.x branch.
>
> Jon, I know you're doing a lot of Java 9 & 10 work.  Would you want to do
> that in both a 7.1 and a 7.0.x or just a 7.1?
>

Good question. I'm fine with a 7.1 as well. The Java 9 and 10 stuff needs
to happen in TomEE 8 as well of course, and I'd like to include 1.7.x as
well as many people still use it.

I appreciate that involves a lot of branches for the Java 9 and 10 work,
but I'm happy to invest the time in that.



> Certainly from a release announcement perspective, "TomEE 7.1 released
> with MicroProfile and Java 10 support" is pretty catchy.
>

I agree.


>
> Preferences?
>
>
> -David
>
> >
> > On Tue, Apr 17, 2018 at 11:25 PM, David Blevins <[hidden email]
> >
> > wrote:
> >
> >> Can we also create a TomEE 7.1?  I think everyone who +1ed was thinking
> >> about something we could release sooner than TomEE 8.x.
> >>
> >>
> >> --
> >> David Blevins
> >> http://twitter.com/dblevins
> >> http://www.tomitribe.com
> >>
> >>> On Apr 17, 2018, at 1:55 PM, Jean-Louis Monteiro <
> >> [hidden email]> wrote:
> >>>
> >>> Thanks guys.
> >>> Yes I meant TomEE 8.x
> >>>
> >>> I have rework the MP-JWT contribution so the extension leaves into a
> >>> different module than the TCK.
> >>> The TCK is green for the MP-JWT.
> >>>
> >>> New PR is here https://github.com/apache/tomee/pull/130
> >>> If you are ok, I will revert from current master the MP-JWT which
> >> requires
> >>> Java 8 and is therefor incompatible with TomEE 7.x
> >>>
> >>> On the TomEE 8.x branch, I'll create an example and push to the same
> PR.
> >>>
> >>>
> >>>
> >>> --
> >>> Jean-Louis Monteiro
> >>> http://twitter.com/jlouismonteiro
> >>> http://www.tomitribe.com
> >>>
> >>> On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <
> [hidden email]>
> >>> wrote:
> >>>
> >>>> +1
> >>>>
> >>>>
> >>>> --
> >>>> David Blevins
> >>>> http://twitter.com/dblevins
> >>>> http://www.tomitribe.com
> >>>>
> >>>>> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
> >>>> [hidden email]> wrote:
> >>>>>
> >>>>> Hi community,
> >>>>>
> >>>>> Most microprofile requires Java 8.
> >>>>> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java
> >> 8)?
> >>>>>
> >>>>> Thanks
> >>>>>
> >>>>>
> >>>>> --
> >>>>> Jean-Louis Monteiro
> >>>>> http://twitter.com/jlouismonteiro
> >>>>> http://www.tomitribe.com
> >>>>
> >>>>
> >>
> >>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Romain Manni-Bucau
What is blocking to release tomee 8? Nothing ;)

Id keep it simple and avoid another maintenance branch.

Le 17 avr. 2018 23:49, "Jonathan Gallimore" <[hidden email]>
a écrit :

> On Tue, 17 Apr 2018, 22:32 David Blevins, <[hidden email]> wrote:
>
> > > On Apr 17, 2018, at 2:26 PM, Jean-Louis Monteiro <
> > [hidden email]> wrote:
> > >
> > > Do we have a branch for it?
> > > Master is 7.x for Java 7
> >
> > Not sure how we want to run that.  One option is we could just switch
> > wherever 7x lives now to 7.1.
> >
> > If we really wanted to patch 7.0.x we could make a 7.0.x branch.
> >
> > Jon, I know you're doing a lot of Java 9 & 10 work.  Would you want to do
> > that in both a 7.1 and a 7.0.x or just a 7.1?
> >
>
> Good question. I'm fine with a 7.1 as well. The Java 9 and 10 stuff needs
> to happen in TomEE 8 as well of course, and I'd like to include 1.7.x as
> well as many people still use it.
>
> I appreciate that involves a lot of branches for the Java 9 and 10 work,
> but I'm happy to invest the time in that.
>
>
>
> > Certainly from a release announcement perspective, "TomEE 7.1 released
> > with MicroProfile and Java 10 support" is pretty catchy.
> >
>
> I agree.
>
>
> >
> > Preferences?
> >
> >
> > -David
> >
> > >
> > > On Tue, Apr 17, 2018 at 11:25 PM, David Blevins <
> [hidden email]
> > >
> > > wrote:
> > >
> > >> Can we also create a TomEE 7.1?  I think everyone who +1ed was
> thinking
> > >> about something we could release sooner than TomEE 8.x.
> > >>
> > >>
> > >> --
> > >> David Blevins
> > >> http://twitter.com/dblevins
> > >> http://www.tomitribe.com
> > >>
> > >>> On Apr 17, 2018, at 1:55 PM, Jean-Louis Monteiro <
> > >> [hidden email]> wrote:
> > >>>
> > >>> Thanks guys.
> > >>> Yes I meant TomEE 8.x
> > >>>
> > >>> I have rework the MP-JWT contribution so the extension leaves into a
> > >>> different module than the TCK.
> > >>> The TCK is green for the MP-JWT.
> > >>>
> > >>> New PR is here https://github.com/apache/tomee/pull/130
> > >>> If you are ok, I will revert from current master the MP-JWT which
> > >> requires
> > >>> Java 8 and is therefor incompatible with TomEE 7.x
> > >>>
> > >>> On the TomEE 8.x branch, I'll create an example and push to the same
> > PR.
> > >>>
> > >>>
> > >>>
> > >>> --
> > >>> Jean-Louis Monteiro
> > >>> http://twitter.com/jlouismonteiro
> > >>> http://www.tomitribe.com
> > >>>
> > >>> On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <
> > [hidden email]>
> > >>> wrote:
> > >>>
> > >>>> +1
> > >>>>
> > >>>>
> > >>>> --
> > >>>> David Blevins
> > >>>> http://twitter.com/dblevins
> > >>>> http://www.tomitribe.com
> > >>>>
> > >>>>> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
> > >>>> [hidden email]> wrote:
> > >>>>>
> > >>>>> Hi community,
> > >>>>>
> > >>>>> Most microprofile requires Java 8.
> > >>>>> Is everyone ok if we have microprofile implemented on TomEE 7.1
> (Java
> > >> 8)?
> > >>>>>
> > >>>>> Thanks
> > >>>>>
> > >>>>>
> > >>>>> --
> > >>>>> Jean-Louis Monteiro
> > >>>>> http://twitter.com/jlouismonteiro
> > >>>>> http://www.tomitribe.com
> > >>>>
> > >>>>
> > >>
> > >>
> >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Mark Struberg-2
In reply to this post by David Blevins-2
There was a discussion about this a few weeks ago where we agreed to ship TomEE-7.0.5 and only then switch to a branch.

That's the reason why we backported tons of stuff in Johnzon, OWB and OpenJPA.
Just waiting for feedback whether it now works fine or if there is still something broken.

So my suggestion is to apply this to the TomEE8 branch and wait with the other PR until TomEE-7.0.5 is released.


LieGrue,
strub



> Am 17.04.2018 um 23:32 schrieb David Blevins <[hidden email]>:
>
>> On Apr 17, 2018, at 2:26 PM, Jean-Louis Monteiro <[hidden email]> wrote:
>>
>> Do we have a branch for it?
>> Master is 7.x for Java 7
>
> Not sure how we want to run that.  One option is we could just switch wherever 7x lives now to 7.1.
>
> If we really wanted to patch 7.0.x we could make a 7.0.x branch.
>
> Jon, I know you're doing a lot of Java 9 & 10 work.  Would you want to do that in both a 7.1 and a 7.0.x or just a 7.1?
>
> Certainly from a release announcement perspective, "TomEE 7.1 released with MicroProfile and Java 10 support" is pretty catchy.
>
>
> Preferences?
>
>
> -David
>
>>
>> On Tue, Apr 17, 2018 at 11:25 PM, David Blevins <[hidden email]>
>> wrote:
>>
>>> Can we also create a TomEE 7.1?  I think everyone who +1ed was thinking
>>> about something we could release sooner than TomEE 8.x.
>>>
>>>
>>> --
>>> David Blevins
>>> http://twitter.com/dblevins
>>> http://www.tomitribe.com
>>>
>>>> On Apr 17, 2018, at 1:55 PM, Jean-Louis Monteiro <
>>> [hidden email]> wrote:
>>>>
>>>> Thanks guys.
>>>> Yes I meant TomEE 8.x
>>>>
>>>> I have rework the MP-JWT contribution so the extension leaves into a
>>>> different module than the TCK.
>>>> The TCK is green for the MP-JWT.
>>>>
>>>> New PR is here https://github.com/apache/tomee/pull/130
>>>> If you are ok, I will revert from current master the MP-JWT which
>>> requires
>>>> Java 8 and is therefor incompatible with TomEE 7.x
>>>>
>>>> On the TomEE 8.x branch, I'll create an example and push to the same PR.
>>>>
>>>>
>>>>
>>>> --
>>>> Jean-Louis Monteiro
>>>> http://twitter.com/jlouismonteiro
>>>> http://www.tomitribe.com
>>>>
>>>> On Tue, Apr 17, 2018 at 8:05 PM, David Blevins <[hidden email]>
>>>> wrote:
>>>>
>>>>> +1
>>>>>
>>>>>
>>>>> --
>>>>> David Blevins
>>>>> http://twitter.com/dblevins
>>>>> http://www.tomitribe.com
>>>>>
>>>>>> On Apr 16, 2018, at 4:11 PM, Jean-Louis Monteiro <
>>>>> [hidden email]> wrote:
>>>>>>
>>>>>> Hi community,
>>>>>>
>>>>>> Most microprofile requires Java 8.
>>>>>> Is everyone ok if we have microprofile implemented on TomEE 7.1 (Java
>>> 8)?
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Jean-Louis Monteiro
>>>>>> http://twitter.com/jlouismonteiro
>>>>>> http://www.tomitribe.com
>>>>>
>>>>>
>>>
>>>
>

Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

David Blevins-2

> On Apr 18, 2018, at 4:08 AM, Mark Struberg <[hidden email]> wrote:
>
> There was a discussion about this a few weeks ago where we agreed to ship TomEE-7.0.5 and only then switch to a branch.
>
> That's the reason why we backported tons of stuff in Johnzon, OWB and OpenJPA.
> Just waiting for feedback whether it now works fine or if there is still something broken.
>
> So my suggestion is to apply this to the TomEE8 branch and wait with the other PR until TomEE-7.0.5 is released.

Kicked off a proper "Status of TomEE 8" thread so we can have a full conversation on what to do with TomEE 8.

If people were willing to put the effort into a TomEE 7.1 in addition to whatever is decided in that thread, would you be ok with a TomEE 7.1 as well?

For context: I know Jean-Louis is heading off to Brazil in May to do a TomEE talk that shows his JWT work.  Ideally he's not showing a snapshot and people could leave with something they can try.  He's doing that talk again in June.

My personal perspective is if the decision was made to release TomEE 8 now, I'd still see value in a 7.1 release with MicroProfile as then the users would have the choice.  Some may not want to do a Java EE 7 to Java EE 8 upgrade, but still want to enjoy some MicroProfile technologies.


-David



Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Mark Struberg-2
Of course having a TomEE-7.1 which bumps the requirement to java8 is cool.
And I fully support that.
But right now let's please focus on shipping TomEE-7.0.5 first.
Most probably 7.1 could be done almost in parallel.
But we do not have endless resources. At least I don't.

LieGrue,
strub

> Am 19.04.2018 um 05:25 schrieb David Blevins <[hidden email]>:
>
>
>> On Apr 18, 2018, at 4:08 AM, Mark Struberg <[hidden email]> wrote:
>>
>> There was a discussion about this a few weeks ago where we agreed to ship TomEE-7.0.5 and only then switch to a branch.
>>
>> That's the reason why we backported tons of stuff in Johnzon, OWB and OpenJPA.
>> Just waiting for feedback whether it now works fine or if there is still something broken.
>>
>> So my suggestion is to apply this to the TomEE8 branch and wait with the other PR until TomEE-7.0.5 is released.
>
> Kicked off a proper "Status of TomEE 8" thread so we can have a full conversation on what to do with TomEE 8.
>
> If people were willing to put the effort into a TomEE 7.1 in addition to whatever is decided in that thread, would you be ok with a TomEE 7.1 as well?
>
> For context: I know Jean-Louis is heading off to Brazil in May to do a TomEE talk that shows his JWT work.  Ideally he's not showing a snapshot and people could leave with something they can try.  He's doing that talk again in June.
>
> My personal perspective is if the decision was made to release TomEE 8 now, I'd still see value in a 7.1 release with MicroProfile as then the users would have the choice.  Some may not want to do a Java EE 7 to Java EE 8 upgrade, but still want to enjoy some MicroProfile technologies.
>
>
> -David
>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

jgallimore
Right now we have JL's change in master as well as TomEE 8. I'm happy to
try and find time to release both. However, I think we're inching very
close with TomEE 7.0.5, so does anyone mind if I create the 7.1 branch, and
shift JL's JWT work there, and take it out of master (7.0.5)?

Jon

On Thu, Apr 19, 2018 at 10:24 AM, Mark Struberg <[hidden email]>
wrote:

> Of course having a TomEE-7.1 which bumps the requirement to java8 is cool.
> And I fully support that.
> But right now let's please focus on shipping TomEE-7.0.5 first.
> Most probably 7.1 could be done almost in parallel.
> But we do not have endless resources. At least I don't.
>
> LieGrue,
> strub
>
> > Am 19.04.2018 um 05:25 schrieb David Blevins <[hidden email]>:
> >
> >
> >> On Apr 18, 2018, at 4:08 AM, Mark Struberg <[hidden email]>
> wrote:
> >>
> >> There was a discussion about this a few weeks ago where we agreed to
> ship TomEE-7.0.5 and only then switch to a branch.
> >>
> >> That's the reason why we backported tons of stuff in Johnzon, OWB and
> OpenJPA.
> >> Just waiting for feedback whether it now works fine or if there is
> still something broken.
> >>
> >> So my suggestion is to apply this to the TomEE8 branch and wait with
> the other PR until TomEE-7.0.5 is released.
> >
> > Kicked off a proper "Status of TomEE 8" thread so we can have a full
> conversation on what to do with TomEE 8.
> >
> > If people were willing to put the effort into a TomEE 7.1 in addition to
> whatever is decided in that thread, would you be ok with a TomEE 7.1 as
> well?
> >
> > For context: I know Jean-Louis is heading off to Brazil in May to do a
> TomEE talk that shows his JWT work.  Ideally he's not showing a snapshot
> and people could leave with something they can try.  He's doing that talk
> again in June.
> >
> > My personal perspective is if the decision was made to release TomEE 8
> now, I'd still see value in a 7.1 release with MicroProfile as then the
> users would have the choice.  Some may not want to do a Java EE 7 to Java
> EE 8 upgrade, but still want to enjoy some MicroProfile technologies.
> >
> >
> > -David
> >
> >
> >
>
>
Reply | Threaded
Open this post in threaded view
|

Re: MP.next()

Romain Manni-Bucau
Hmm,

I don't get the rational of having a 7.x with that. Any reason?
Technically TomEE 8 is way more ready to release than TomEE 7.1 ;).


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://rmannibucau.metawerx.net/> | Old Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Book
<https://www.packtpub.com/application-development/java-ee-8-high-performance>

2018-04-19 12:00 GMT+02:00 Jonathan Gallimore <[hidden email]>
:

> Right now we have JL's change in master as well as TomEE 8. I'm happy to
> try and find time to release both. However, I think we're inching very
> close with TomEE 7.0.5, so does anyone mind if I create the 7.1 branch, and
> shift JL's JWT work there, and take it out of master (7.0.5)?
>
> Jon
>
> On Thu, Apr 19, 2018 at 10:24 AM, Mark Struberg <[hidden email]
> >
> wrote:
>
> > Of course having a TomEE-7.1 which bumps the requirement to java8 is
> cool.
> > And I fully support that.
> > But right now let's please focus on shipping TomEE-7.0.5 first.
> > Most probably 7.1 could be done almost in parallel.
> > But we do not have endless resources. At least I don't.
> >
> > LieGrue,
> > strub
> >
> > > Am 19.04.2018 um 05:25 schrieb David Blevins <[hidden email]
> >:
> > >
> > >
> > >> On Apr 18, 2018, at 4:08 AM, Mark Struberg <[hidden email]
> >
> > wrote:
> > >>
> > >> There was a discussion about this a few weeks ago where we agreed to
> > ship TomEE-7.0.5 and only then switch to a branch.
> > >>
> > >> That's the reason why we backported tons of stuff in Johnzon, OWB and
> > OpenJPA.
> > >> Just waiting for feedback whether it now works fine or if there is
> > still something broken.
> > >>
> > >> So my suggestion is to apply this to the TomEE8 branch and wait with
> > the other PR until TomEE-7.0.5 is released.
> > >
> > > Kicked off a proper "Status of TomEE 8" thread so we can have a full
> > conversation on what to do with TomEE 8.
> > >
> > > If people were willing to put the effort into a TomEE 7.1 in addition
> to
> > whatever is decided in that thread, would you be ok with a TomEE 7.1 as
> > well?
> > >
> > > For context: I know Jean-Louis is heading off to Brazil in May to do a
> > TomEE talk that shows his JWT work.  Ideally he's not showing a snapshot
> > and people could leave with something they can try.  He's doing that talk
> > again in June.
> > >
> > > My personal perspective is if the decision was made to release TomEE 8
> > now, I'd still see value in a 7.1 release with MicroProfile as then the
> > users would have the choice.  Some may not want to do a Java EE 7 to Java
> > EE 8 upgrade, but still want to enjoy some MicroProfile technologies.
> > >
> > >
> > > -David
> > >
> > >
> > >
> >
> >
>
12